using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d([0-9]{6})([0-9]{0,16})([0-9]{4})\d";
string substitution = @"$1******$3";
string input = @"Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa
Aaaa bbbb aaa=\""1234567890123456\"" fdfdfd=aaa
Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}