package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d([0-9]{6})([0-9]{0,16})([0-9]{4})\d`)
var str = `Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa
Aaaa bbbb aaa=\"1234567890123456\" fdfdfd=aaa
Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa`
var substitution = "$1******$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}