import Foundation
let pattern = #"\d([0-9]{6})([0-9]{0,16})([0-9]{4})\d"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa
Aaaa bbbb aaa=\"1234567890123456\" fdfdfd=aaa
Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1******$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)