using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( {4})";
string input = @"<?xml version=""1.0"" encoding=""utf-8"" standalone=""no""?>
<customroot>
<customtaga id=""some-ida"">
<customtagb class=""some-classb"" x=""1.25"" y=""0.3"">
<customtagc class=""some-classc"" values=""points=""1.0,2.0 3.0,4.0 5.0,6.0"" />
</customtagb>
</customtaga>
</customroot>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}