# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"( {4})"
test_str = ("<?xml version=\"1.0\" encoding=\"utf-8\" standalone=\"no\"?>\n"
"<customroot>\n"
" <customtaga id=\"some-ida\">\n"
" <customtagb class=\"some-classb\" x=\"1.25\" y=\"0.3\">\n"
" <customtagc class=\"some-classc\" values=\"points=\"1.0,2.0 3.0,4.0 5.0,6.0\" />\n"
" </customtagb>\n"
" </customtaga>\n"
"</customroot>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.