re = /( {4})/m
str = '<?xml version="1.0" encoding="utf-8" standalone="no"?>
<customroot>
<customtaga id="some-ida">
<customtagb class="some-classb" x="1.25" y="0.3">
<customtagc class="some-classc" values="points="1.0,2.0 3.0,4.0 5.0,6.0" />
</customtagb>
</customtaga>
</customroot>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end