use strict;
my $str = '<?xml version="1.0" encoding="utf-8" standalone="no"?>
<customroot>
<customtaga id="some-ida">
<customtagb class="some-classb" x="1.25" y="0.3">
<customtagc class="some-classc" values="points="1.0,2.0 3.0,4.0 5.0,6.0" />
</customtagb>
</customtaga>
</customroot>';
my $regex = qr/( {4})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}