package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)( {4})`)
var str = `<?xml version="1.0" encoding="utf-8" standalone="no"?>
<customroot>
<customtaga id="some-ida">
<customtagb class="some-classb" x="1.25" y="0.3">
<customtagc class="some-classc" values="points="1.0,2.0 3.0,4.0 5.0,6.0" />
</customtagb>
</customtaga>
</customroot>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}