import Foundation
let pattern = #"( {4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<?xml version="1.0" encoding="utf-8" standalone="no"?>
<customroot>
<customtaga id="some-ida">
<customtagb class="some-classb" x="1.25" y="0.3">
<customtagc class="some-classc" values="points="1.0,2.0 3.0,4.0 5.0,6.0" />
</customtagb>
</customtaga>
</customroot>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)