const regex = /( {4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('( {4})', 'gm')
const str = `<?xml version="1.0" encoding="utf-8" standalone="no"?>
<customroot>
<customtaga id="some-ida">
<customtagb class="some-classb" x="1.25" y="0.3">
<customtagc class="some-classc" values="points="1.0,2.0 3.0,4.0 5.0,6.0" />
</customtagb>
</customtaga>
</customroot>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}