import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( {4})";
final String string = "<?xml version=\"1.0\" encoding=\"utf-8\" standalone=\"no\"?>\n"
+ "<customroot>\n"
+ " <customtaga id=\"some-ida\">\n"
+ " <customtagb class=\"some-classb\" x=\"1.25\" y=\"0.3\">\n"
+ " <customtagc class=\"some-classc\" values=\"points=\"1.0,2.0 3.0,4.0 5.0,6.0\" />\n"
+ " </customtagb>\n"
+ " </customtaga>\n"
+ "</customroot>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}