#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?:\.if|\.else)(.*?)(?:\.else|\.endif)"
Local $sString = ".if CONDITION1" & @CRLF & _
"code1" & @CRLF & _
".elseif CONDITION2" & @CRLF & _
"code2" & @CRLF & _
".else" & @CRLF & _
"code3" & @CRLF & _
".endif"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")