using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\.if|\.else)(.*?)(?:\.else|\.endif)";
string input = @".if CONDITION1
code1
.elseif CONDITION2
code2
.else
code3
.endif";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}