import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\.if|\\.else)(.*?)(?:\\.else|\\.endif)";
final String string = ".if CONDITION1\n"
+ "code1\n"
+ ".elseif CONDITION2\n"
+ "code2\n"
+ ".else\n"
+ "code3\n"
+ ".endif";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}