$re = '/(?:\.if|\.else)(.*?)(?:\.else|\.endif)/ms';
$str = '.if CONDITION1
code1
.elseif CONDITION2
code2
.else
code3
.endif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);