const regex = /(?:\.if|\.else)(.*?)(?:\.else|\.endif)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\.if|\\.else)(.*?)(?:\\.else|\\.endif)', 'gms')
const str = `.if CONDITION1
code1
.elseif CONDITION2
code2
.else
code3
.endif`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}