re = /(?:\.if|\.else)(.*?)(?:\.else|\.endif)/m
str = '.if CONDITION1
code1
.elseif CONDITION2
code2
.else
code3
.endif'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end