// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)(?:\.if|\.else)(.*?)(?:\.else|\.endif)").unwrap();
let string = ".if CONDITION1
code1
.elseif CONDITION2
code2
.else
code3
.endif";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}