# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(&\w+;\w+&\w+;;);+|(\n\w+;);+/$1$2/uig;t' <<< "«Hi»
«Hi»;
«Hi»;;
«Hi»;;;;;;
Hi;
Hi;;
Hi;;;
Hi;;;;"