re = /(&\w+;\w+&\w+;;);+|(\n\w+;);+/i
str = '«Hi»
«Hi»;
«Hi»;;
«Hi»;;;;;;
Hi;
Hi;;
Hi;;;
Hi;;;;'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result