package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(&\w+;\w+&\w+;;);+|(\n\w+;);+`)
var str = `«Hi»
«Hi»;
«Hi»;;
«Hi»;;;;;;
Hi;
Hi;;
Hi;;;
Hi;;;;`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}