#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ui)(&\w+;\w+&\w+;;);+|(\n\w+;);+"
Local $sString = "«Hi»" & @CRLF & _
"«Hi»;" & @CRLF & _
"«Hi»;;" & @CRLF & _
"«Hi»;;;;;;" & @CRLF & _
"Hi;" & @CRLF & _
"Hi;;" & @CRLF & _
"Hi;;;" & @CRLF & _
"Hi;;;;"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)