const regex = /(&\w+;\w+&\w+;;);+|(\n\w+;);+/uig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(&\\w+;\\w+&\\w+;;);+|(\\n\\w+;);+', 'uig')
const str = `«Hi»
«Hi»;
«Hi»;;
«Hi»;;;;;;
Hi;
Hi;;
Hi;;;
Hi;;;;`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);