import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(&\\w+;\\w+&\\w+;;);+|(\\n\\w+;);+";
final String string = "«Hi»\n"
+ "«Hi»;\n"
+ "«Hi»;;\n"
+ "«Hi»;;;;;;\n"
+ "Hi;\n"
+ "Hi;;\n"
+ "Hi;;;\n"
+ "Hi;;;;";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}