using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(&\w+;\w+&\w+;;);+|(\n\w+;);+";
string substitution = @"$1$2";
string input = @"«Hi»
«Hi»;
«Hi»;;
«Hi»;;;;;;
Hi;
Hi;;
Hi;;;
Hi;;;;";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}