use strict;
my $str = '«Hi»
«Hi»;
«Hi»;;
«Hi»;;;;;;
Hi;
Hi;;
Hi;;;
Hi;;;;';
my $regex = qr/(&\w+;\w+&\w+;;);+|(\n\w+;);+/uip;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";