# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/".*?"(*SKIP)(*FAIL)|(\w+\s[<>@]\s\w+)/"$1"/g;t' <<< "Neuman@BBN-TENEXA
Alfred > Neuman <Neuman@BBN-TENEXA>
Alfred > Neuman <Neuman@BBN-TENEXA>, Alfred Neuman <Neuman@BBN-TENEXA>, \"Alfred > Neuman\" <Neuman@BBN-TENEXA>, Alfred > Neuman <Neuman@BBN-TENEXA>
\"Alfred > Neuman\" <Neuman@BBN-TENEXA>
Alfred @ Neuman <Neuman@BBN-TENEXA>"