using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @""".*?""(*SKIP)(*FAIL)|(\w+\s[<>@]\s\w+)";
string substitution = @"""$1""";
string input = @"Neuman@BBN-TENEXA
Alfred > Neuman <Neuman@BBN-TENEXA>
Alfred > Neuman <Neuman@BBN-TENEXA>, Alfred Neuman <Neuman@BBN-TENEXA>, ""Alfred > Neuman"" <Neuman@BBN-TENEXA>, Alfred > Neuman <Neuman@BBN-TENEXA>
""Alfred > Neuman"" <Neuman@BBN-TENEXA>
Alfred @ Neuman <Neuman@BBN-TENEXA>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}