$re = '/".*?"(*SKIP)(*FAIL)|(\w+\s[<>@]\s\w+)/';
$str = 'Neuman@BBN-TENEXA
Alfred > Neuman <Neuman@BBN-TENEXA>
Alfred > Neuman <Neuman@BBN-TENEXA>, Alfred Neuman <Neuman@BBN-TENEXA>, "Alfred > Neuman" <Neuman@BBN-TENEXA>, Alfred > Neuman <Neuman@BBN-TENEXA>
"Alfred > Neuman" <Neuman@BBN-TENEXA>
Alfred @ Neuman <Neuman@BBN-TENEXA>';
$subst = "\"$1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;