import Foundation
let pattern = #"".*?"(*SKIP)(*FAIL)|(\w+\s[<>@]\s\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Neuman@BBN-TENEXA
Alfred > Neuman <Neuman@BBN-TENEXA>
Alfred > Neuman <Neuman@BBN-TENEXA>, Alfred Neuman <Neuman@BBN-TENEXA>, "Alfred > Neuman" <Neuman@BBN-TENEXA>, Alfred > Neuman <Neuman@BBN-TENEXA>
"Alfred > Neuman" <Neuman@BBN-TENEXA>
Alfred @ Neuman <Neuman@BBN-TENEXA>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""$1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)