import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\".*?\"(*SKIP)(*FAIL)|(\\w+\\s[<>@]\\s\\w+)";
final String string = "Neuman@BBN-TENEXA\n"
+ "Alfred > Neuman <Neuman@BBN-TENEXA>\n"
+ "Alfred > Neuman <Neuman@BBN-TENEXA>, Alfred Neuman <Neuman@BBN-TENEXA>, \"Alfred > Neuman\" <Neuman@BBN-TENEXA>, Alfred > Neuman <Neuman@BBN-TENEXA>\n"
+ "\"Alfred > Neuman\" <Neuman@BBN-TENEXA>\n"
+ "Alfred @ Neuman <Neuman@BBN-TENEXA>";
final String subst = "\"$1\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}