use strict;
my $str = 'Neuman@BBN-TENEXA
Alfred > Neuman <Neuman@BBN-TENEXA>
Alfred > Neuman <Neuman@BBN-TENEXA>, Alfred Neuman <Neuman@BBN-TENEXA>, "Alfred > Neuman" <Neuman@BBN-TENEXA>, Alfred > Neuman <Neuman@BBN-TENEXA>
"Alfred > Neuman" <Neuman@BBN-TENEXA>
Alfred @ Neuman <Neuman@BBN-TENEXA>';
my $regex = qr/".*?"(*SKIP)(*FAIL)|(\w+\s[<>@]\s\w+)/p;
my $subst = '"$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";