#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)\s+S(\d{2})E(\d{2})[\- ]+(.*)"
Local $sString = "12 Monkeys S02E10 - Fatherland.txt" & @CRLF & _
"Colony S02E01 - Eleven Thirteen.txt" & @CRLF & _
"Prison Break S05E05 - Contingency.txt"
Local $sSubst = "$1,$2,$3,$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)