import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)\\s+S(\\d{2})E(\\d{2})[\\- ]+(.*)";
final String string = "12 Monkeys S02E10 - Fatherland.txt\n"
+ "Colony S02E01 - Eleven Thirteen.txt\n"
+ "Prison Break S05E05 - Contingency.txt";
final String subst = "$1,$2,$3,$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}