use strict;
my $str = '12 Monkeys S02E10 - Fatherland.txt
Colony S02E01 - Eleven Thirteen.txt
Prison Break S05E05 - Contingency.txt';
my $regex = qr/(.*)\s+S(\d{2})E(\d{2})[\- ]+(.*)/mp;
my $subst = '$1,$2,$3,$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";