$re = '/(.*)\s+S(\d{2})E(\d{2})[\- ]+(.*)/m';
$str = '12 Monkeys S02E10 - Fatherland.txt
Colony S02E01 - Eleven Thirteen.txt
Prison Break S05E05 - Contingency.txt';
$subst = "$1,$2,$3,$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;