# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"((?:\\["'\\bfnrt]|[^\\"'\n\r])*)"/'$1'/g;t' <<< "\"\"
\"test\"
\"te\\"st\"
\"te
st\"
\"multi\nline\twith\bweird\fcharacters\reverywhere\"
\"but'no'single'quotes\""