const regex = /"((?:\\["'\\bfnrt]|[^\\"'\n\r])*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"((?:\\\\["\'\\\\bfnrt]|[^\\\\"\'\\n\\r])*)"', 'g')
const str = `""
"test"
"te\\"st"
"te
st"
"multi\\nline\\twith\\bweird\\fcharacters\\reverywhere"
"but'no'single'quotes"`;
const subst = `'$1'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);