// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""((?:\\["'\\bfnrt]|[^\\"'\n\r])*)""#).unwrap();
let string = "\"\"
\"test\"
\"te\\\"st\"
\"te
st\"
\"multi\\nline\\twith\\bweird\\fcharacters\\reverywhere\"
\"but'no'single'quotes\"";
let substitution = "'$1'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}