#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""((?:\\["'\\bfnrt]|[^\\"'\n\r])*)""
Local $sString = """" & @CRLF & _
""test"" & @CRLF & _
""te\"st"" & @CRLF & _
""te" & @CRLF & _
"st"" & @CRLF & _
""multi\nline\twith\bweird\fcharacters\reverywhere"" & @CRLF & _
""but'no'single'quotes""
Local $sSubst = "'$1'"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)