using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""((?:\\[""'\\bfnrt]|[^\\""'\n\r])*)""";
string substitution = @"'$1'";
string input = @"""
""test""
""te\""st""
""te
st""
""multi\nline\twith\bweird\fcharacters\reverywhere""
""but'no'single'quotes""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}