import Foundation
let pattern = #""((?:\\["'\\bfnrt]|[^\\"'\n\r])*)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
""
"test"
"te\"st"
"te
st"
"multi\nline\twith\bweird\fcharacters\reverywhere"
"but'no'single'quotes"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'$1'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)