package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"((?:\\["'\\bfnrt]|[^\\"'\n\r])*)"`)
var str = `""
"test"
"te\"st"
"te
st"
"multi\nline\twith\bweird\fcharacters\reverywhere"
"but'no'single'quotes"`
var substitution = "'$1'"
fmt.Println(re.ReplaceAllString(str, substitution))
}