$re = '/"((?:\\\\["\'\\\\bfnrt]|[^\\\\"\'\n\r])*)"/';
$str = '""
"test"
"te\\"st"
"te
st"
"multi\\nline\\twith\\bweird\\fcharacters\\reverywhere"
"but\'no\'single\'quotes"';
$subst = "'$1'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;