#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^hostname\s*(.*?)(?:-[ps])?$"
Local $sString = "terminal width 120" & @CRLF & _
"hostname IGN-HSHST-HSH-01-P" & @CRLF & _
"domain-name sample.com" & @CRLF & _
"" & @CRLF & _
"hostname ign-hshst-hsh-01-p" & @CRLF & _
"hostname ign-hshst-hsh-02-p" & @CRLF & _
"hostname ign-hshst-hsd-10" & @CRLF & _
"hostname ign-hshst-hsh-01-S" & @CRLF & _
"hostname ign-hshst-hsd-11" & @CRLF & _
"hostname ign-hshst-hsh-02-s"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")