import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^hostname\\s*(.*?)(?:-[ps])?$";
final String string = "terminal width 120\n"
+ "hostname IGN-HSHST-HSH-01-P\n"
+ "domain-name sample.com\n\n"
+ "hostname ign-hshst-hsh-01-p\n"
+ "hostname ign-hshst-hsh-02-p\n"
+ "hostname ign-hshst-hsd-10\n"
+ "hostname ign-hshst-hsh-01-S\n"
+ "hostname ign-hshst-hsd-11\n"
+ "hostname ign-hshst-hsh-02-s";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}