using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^hostname\s*(.*?)(?:-[ps])?$";
string input = @"terminal width 120
hostname IGN-HSHST-HSH-01-P
domain-name sample.com
hostname ign-hshst-hsh-01-p
hostname ign-hshst-hsh-02-p
hostname ign-hshst-hsd-10
hostname ign-hshst-hsh-01-S
hostname ign-hshst-hsd-11
hostname ign-hshst-hsh-02-s";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}