import Foundation
let pattern = #"^hostname\s*(.*?)(?:-[ps])?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
terminal width 120
hostname IGN-HSHST-HSH-01-P
domain-name sample.com
hostname ign-hshst-hsh-01-p
hostname ign-hshst-hsh-02-p
hostname ign-hshst-hsd-10
hostname ign-hshst-hsh-01-S
hostname ign-hshst-hsd-11
hostname ign-hshst-hsh-02-s
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)