re = /^hostname\s*(.*?)(?:-[ps])?$/mi
str = 'terminal width 120
hostname IGN-HSHST-HSH-01-P
domain-name sample.com
hostname ign-hshst-hsh-01-p
hostname ign-hshst-hsh-02-p
hostname ign-hshst-hsd-10
hostname ign-hshst-hsh-01-S
hostname ign-hshst-hsd-11
hostname ign-hshst-hsh-02-s'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end