// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^hostname\s*(.*?)(?:-[ps])?$").unwrap();
let string = "terminal width 120
hostname IGN-HSHST-HSH-01-P
domain-name sample.com
hostname ign-hshst-hsh-01-p
hostname ign-hshst-hsh-02-p
hostname ign-hshst-hsd-10
hostname ign-hshst-hsh-01-S
hostname ign-hshst-hsd-11
hostname ign-hshst-hsh-02-s";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}